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File Menu
New
Clears the drawing and sets the current filename to "noname.kwk" (displayed in the caption 
bar at the top of the drawing).

Open
Shows the disk directory and allows you to open a new file.    The Open dialog box will also 
allow you to change the current directory.

Save
Saves the drawing to disk under the current filename (as displayed in the caption bar at the 
top of the drawing).    If the caption bar is labelled "KWIKDRAW", then the current filename is 
actually "noname.kwk".

Save As
Allows you to save the drawing with a new filename.    The Save As dialog box will not allow 
you to change the current directory.    You can, however, save to a file in a different directory 
by prefixing the filename with a directory path.

Print
Brings up the print popup menu.    You will probably want to set the printer orientation to 
match the screen orientation (portrait or landscape).    To do this, use the "Setup" button on 
the print popup menu.    KwikDraw will automatically scale the screen drawing to the paper 
size of your printer.

Print Setup
This menu option allows you to change your default printer by launching the Printers portion 
of the Windows Control Panel.    To change printers, double-click on a new printer to make it 
the default.

Exit
Quits KwikDraw.    You will be asked whether you wish to save the current drawing before 
quitiing.



Edit Menu
Undo
Undoes the last change made to an object, or a set of objects.    Use this option to undo the 
following changes:    Moved objects, Scaled objects, Polygon vertex changes, Text changes, 
Curve extent changes, Line arrowhead changes, Rotate, Fill Pattern changes, Line style 
changes, and Font changes.    To Redo something that you have undone, simply select Undo 
again (Undo the Undo).    To undo a Flip operation, perform the Flip again.    To undo Group 
Objects, use Ungroup Objects (and visa-versa).    To undo Object Forward, use Object 
Backward (and visa-versa).    To undo Cut, use Paste (and visa-versa).    To undo Duplicate, 
use Cut.

Cut to Clipboard
Cuts the currently selected objects into the Windows Clipboard.    Objects in the Windows 
Clipboard may be pasted into the current drawing, into a newly loaded drawing, into a 
drawing in another session of KwikDraw, or into any application that supports MetaFile 
formats, which includes most Windows based word processors and drawing programs.

Copy to Clipboard
Copies the currently selected objects into the Windows Clipboard.

Paste from Clipboard
If the Windows Clipboard currently contains any KwikDraw objects, then they will be pasted 
into the current drawing.    The objects will be pasted in a selected state so that you can 
easily move them about.

Show Clipboard
Launches the Windows Clipboard.    This is a convenient way to view or resize the contents of
the clipboard before pasting into another application.    For more information on this, see 
Transfer to Other Applications.

Duplicate
Duplicates the selected items, leaving the newly created objects in a selected state.

Text Edit
Allows you to edit a previously placed text object.    A single text object must be selected 
before this menu item can be used.    You can also edit a text object by double clicking on it 
with the pointer tool, or by selecting it and then pressing the right mouse button.

Edit Poly 
When checked, this menu item indicates that you are currently in "Edit Poly" mode.    In this 
mode, the vertices of polygon objects may be altered by pointing at them, holding the left 
button down, and dragging the mouse.    In order to scale a Polygon object by stretching one 
of the corners, the Edit Poly mode must be turned off.    Selecting this menu item will toggle 
the Edit Poly mode on or off.

Extend Curve 
When checked, this menu item indicates that you are currently in "Extend Curve" mode.    
Curve type objects (curve, pie, or chord) are initially created as one quadrant of an ellipse.    
In the "Extend Curve" mode, the endpoints of Curve type objects may be lengthened or 
shortened by pointing at them, holding the left button down, and dragging the mouse.    In 
order to scale a curve object by stretching one of the corners, the Extend Curve mode must 
be turned off.    Selecting this menu item will toggle the Extend Curve mode on or off.



Layout Menu
Show Grid
This menu item toggles the grid display on and off.

Snap to Grid
This menu item toggles the grid snap mode on and off.    When grid snap is on, you will only 
be allowed to draw, move, and stretch objects to the nearest grid points.

Constrain
This menu item toggles the Constrain mode on and off.    When Constrain is on, new objects, 
other than Lines or Polygons, will only be drawn with a one-to-one aspect ratio.    Thus only 
Squares will be drawn when using the Rectangle tool, and only Circles will be drawn when 
using the Ellipse tool, etc.    Line objects, and the line components of Polygon objects, will 
only be drawn horizontally, vertically, or at 45 degree angles in the Constrain mode.    When 
resizing or stretching objects, the Constrain mode will prevent you from changing the aspect
ratio of the object.    This means that changing the size of an object in one dimension can 
only occur with a proportionally equal change in the other dimension.

Drawing Size 600x800 and 1200x1600
These menu selections control the size of the drawing surface on the screen.    The drawing 
size is expressed as the number of screen pixels in the drawing area at a 100% zoom 
setting.    Selecting one of these two sizes will uncheck the other.    Note that this only 
controls the size of the drawing on the screen.    The size of the printed output is determined 
by the page size of your printer.    KwikDraw will automatically scale the screen page to fit on
your printer page.

Portrait and Landscape
These menu selections control the orientation of the drawing on the screen.    Selecting one 
of these will uncheck the other.    Note that this only controls the orientation of the screen 
page.    The orientation of the printer output is controlled separately from the Print menu.    In
most cases you will want to use the same orientation for both screen and printer.    KwikDraw
will, however, automatically scale the screen page to fit on your printer page.

Zoom
These menu items control the zoom level of the screen page.    When the zoom level is less 
than 100%, then text objects in one of the Raster Fonts are only shown as an outline.    Text 
objects in one of the Stroke Fonts are displayed as normal, however.



Raster Fonts

The Raster Fonts are Courier, Helv, Tms Rmn, and Symbol.



Stroke Fonts

The Stroke Fonts are Roman, Modern, and Script.



Solid Colors

Solid Colors are those that can be obtained directly from your video hardware for each 
display pixel.



Dithered Colors

Dithered Colors are generated (by MS Windows) by placing display pixels with different solid 
colors adjacent to each other.    If you are standing far enough away from your monitor, your 
eyes will "mix" the adjacent pixels to give the effect of a color that your video hardware 
cannot otherwise generate directly.



Arrange Menu
Move Forward
This menu item will move the currently selected item on top of the first item found that 
overlaps it.    When multiple items are selected, this procedure is applied to each item in the 
order that the items were selected.    The results can be confusing since the next item Moved
Forward could undo the result of the last item Moved Forward.    Similar comments apply to 
the other Move selections.

Move Backwards
Moves the currently selected item below the first item found that it overlaps.

Move to Front
Moves the currently selected item to the top of all items that overlap it.

Move to Back
Moves the currently selected item to the bottom of all items that it overlaps.

Flip Horizontal
Flips the selected items horizontally about their individual center points.    The items that 
make up a Grouped object will be flipped about the center of the Group.

Flip Vertical
Flips the selected items vertically about their individual center points.    The items that make 
up a Grouped object will be flipped about the center of the Group.

Rotate
Rotates the selected items 90 degrees about their individual center points.    The items that 
make up a Grouped object will be rotated about the center of the Group.    Text Objects can 
only be rotated about their own center points when they use one of the Stroke Fonts.    When
part of a Grouped Object, however, the position of a Text object using one of the Raster 
Fonts will still    rotate about the center of the group.

Group
Combines the selected object into a grouped object, which can be moved, stretched, flipped,
rotated, etc as a single entity.    Groups of Groups can be formed to an arbitrary number of 
levels.

Ungroup
Ungroups the selected Group objects back one level into independent entities.    Note that 
Ungrouping a Group of Groups takes you back only one level instead of all the way back to 
the base object types.



Pen Menu
The selections and dialog boxes launched from this menu are context sensitive.    When no 
objects are currently selected, this menu and its associated dialog boxes show you (and 
allow you to modify) the current defaults for Fill Patterns, Line Widths, Line Types, and Line 
Arrowheads.    When a single object is selected, the menu and dialog box items show and 
modify the attributes of only that object, WITHOUT changing the defaults that will be used 
for newly created objects.    When multiple objects or Grouped objects are selected, the 
menu and dialog boxes will show nothing checked, since the selected objects may all have 
different settings.    In this case, when you choose a menu or dialog box item, it will set the 
corresponding attribute of ALL currently selected items, again WITHOUT modifying the 
default attributes.

Fill
Launches a dialog box that allows you to change the Fill Pattern and the Fill Color for closed 
objects (rectangles, ellipses, closed curves, and closed polygons).

Line Style
Launches a dialog box that allows you to change the Line Width, Line Style, and Line Color 
for any object other than Text Objects.    Only solid lines may be given a width greater than 1 
in this dialog box.    If any of the dotted or dashed line styles is selected, the width will be 
forced to 1, and the width entry field on the dialog box will be disabled.

Arrow Style
Launches a dialog box that allows you to change the Arrowhead Style for Line Objects.

Arrows
These menu items only apply to Line objects.    The attributes of the selected object are 
shown as a check mark next to the Left Arrow or Right Arrow menu items (or both).    Any of 
the menu items Left Arrow, Right Arrow, No Arrows, or Both Arrows, may be chosen to alter 
the selected object.    The Left Arrow and Right Arrow items act as toggles.



Font Menu
This menu only applies to Text objects.    The selections are context sensitive.    When no 
objects are currently selected, this menu shows you (and allows you to modify) the current 
defaults for Font Type and Style.    When a single object is selected, the menu shows the 
attributes of only that object, WITHOUT changing the defaults that will be used for newly 
created Text objects.    When multiple objects or Grouped objects are selected, the menu will 
show nothing checked, since the selected objects may all have different settings.    In this 
case, when you choose a menu item, it will set the corresponding attribute of ALL currently 
selected items, again WITHOUT modifying the default attributes.

Raster Fonts
The first group of font types on this menu are Raster Fonts.    They are not arbitrarily 
scalable.    Text objects using these font types are shown as outlines when the zoom level is 
below 100%.    Text objects using these fonts cannot be rotated about their own centers.

Stroke Fonts
The second group of font types on this menu are Stroke Fonts.    Text objects using these font
types may be viewed at any zoom level.    They may also be rotated about their own centers.

Font Style
The last group on this menu controls the font style (Normal, Bold, Italic, or Underline).



Size Menu
This menu only applies to Text objects.    The selections are context sensitive.    When no 
objects are currently selected, this menu shows you (and allows you to modify) the current 
defaults for Font Size.    When a single object is selected, the menu shows the Font Size of 
only that object, WITHOUT changing the default that will be used for newly created Text 
objects.    When multiple objects or Grouped objects are selected, the menu will show 
nothing checked, since the selected objects may all have different sizes.    In this case, when 
you choose a size, it will set the corresponding attribute of ALL currently selected text 
objects, again WITHOUT modifying the default size.



Help on KwikDraw Tool Bar
Pointer Tool
Text Tool
Line Tool
Rectangle Tools
Ellipse Tool
Arc, Chord, Pie Tools
Polygon Tools



Pointer Tool
This tool is used to Select objects.    An object must be selected before it can be moved, 
rescaled, copied, cut, duplicated, edited, moved forward, moved backward, flipped, rotated, 
grouped, ungrouped, or had any of its attributes modified (such as pen style, pen width, fill 
pattern, font type, font style, or font size).



Text Tool
This tool is used to place a text object on the drawing.    After activating the tool, simply 
point to the entry point on your drawing, then click and release the left mouse button.    A 
text entry dialog box will pop up.    Type the text desired and terminate by pressing the OK or
Cancel buttons.    During text entry you may use the Enter key to start a new line.    You may 
also edit your text using the cursor keys, the backspace key, and the delete key.    To replace 
a block of text, simply highlight the block to be replaced and start typing the new text.

You may initiate edits to an existing Text object in three ways.    Any of the methods below 
will pop-up a dialog box which will allow you to edit the text:

Using the Edit Menu:
To use this method, first select the Text object.    Then choose the Edit Text option on the Edit
Menu.

Double-Clicking:
To use this method simply double-click on the text object using the left mouse button.

Using the Right Mouse Button:
To use this method, first select the Text object.    Then press the right mouse button.



Line Tool
This tool is used to draw lines.    After activating the tool, simply point where you desire the 
start of the line, click and hold down the left mouse button, drag the cursor to where you 
desire the end of the line, and release the mouse button.    Arrowheads may be added to line 
objects using the options on the Pen Menu.    The line style or width may be altered using the
Line Style option on the Pen Menu.



Rectangle Tools
There are two tools to draw rectangles, one for regular rectangles and another for rectangles
with rounded corners.    After activating one of these tools, simply point where you desire one
of the rectangle corners, click and hold the left mouse button, drag the cursor to where you 
desire the opposite corner, and release the mouse button.    The rectangle fill pattern may be
altered using the Fill option on the Pen Menu.    The line style or width may altered using the 
Line Style option on the Pen Menu.



Ellipse Tool
This tool is used to draw ellipses, including circles.    Drawing an ellipse is identical to 
drawing a rectangle that surrounds the desired ellipse.    After activating the tool, simply 
point where you desire one of the rectangle corners, click and hold the left mouse button, 
drag the cursor to where you desire the opposite corner, and release the mouse button.    
The ellipse fill pattern may be altered using the Fill option on the Pen Menu.    The line style 
or width may altered using the Line Style option on the Pen Menu.



Arc, Chord, Pie Tools
Curved regions are drawn as a portion an ellipse.    There are three tools for drawing curved 
regions, one for drawing Arcs, which are open curves, one for Chords, which connect the 
endpoints of an arc with a straight line, and one for Pies, which connect the endpoints of an 
arc with two straight lines meeting at the center of the ellipse.    Arc, Chord, and Pie objects 
are initially drawn as one quadrant of an ellipse.    The endpoints may be extended away 
from the quadrant boundary when in the Extend Curve mode, controllable from the Edit 
Menu.    Drawing one of these objects is identical to drawing a rectangle that surrounds the 
quadrant of the underlying ellipse.    After activating the tool, simply point where you desire 
one of the rectangle corners, click and hold the left mouse button, drag the cursor to where 
you desire the opposite corner, and release the mouse button.    The fill pattern for the Chord
and Pie objects may be altered using the Fill option on the Pen Menu.    The line style or width
may altered using the Line Style option on the Pen Menu.



Polygon Tools
There are two tools to draw Polygons, one for Closed Polygons and another for Open 
Polygons.    After activating one of these tools, simply point where you desire one of the 
polygon vertices, then click and release the left mouse button.    Next move the mouse 
cursor to the next vertex and click and release again.    To finish the Polygon, you must 
double-click the left mouse button or single click the right mouse button on the last vertex.    
Closed Polygons will automatically be connected back to the starting vertex.    After finishing 
the object, Polygon vertices may be individually moved when in the Edit Polygon mode,    
controllable from the Edit Menu.    The Closed Polygon fill pattern may be altered using the 
Fill option on the Pen Menu.    The line style or width may altered using the Line Style option 
on the Pen Menu.



Help on General Topics
Open, Save, or Rename a Drawing
Printing a Drawing
Transfer to Other Applications
Making Objects Transparent
Coloring Objects
Modifying Objects
Moving Objects
Editing Existing Text
Selecting Objects
Grouping Objects
Undo Changes
Scrolling Speed



Open, Save, or Rename a Drawing
To open an existing drawing, use the Open option on the File Menu.

To start a new drawing, use the New option on the File Menu.

To save your work under the current filename, use the Save option on the File Menu.    The 
current filename is usually displayed above the menu.    If "KWIKDRAW" is currently displayed
above the menu, then the current filename is "noname.kwk".

To save your work under a different filename, use the Save As option on the File Menu.



Printing a Drawing
To print a drawing, use the Print option on the File Menu.



Transfer to Other Applications
You can copy a drawing, or any portion of a drawing to any application that supports 
Windows MetaFiles using the Windows Clipboard.    This includes most word processors and 
drawing programs that run under Windows.

To transfer a drawing to another application through the Windows Clipboard:

1) Select the portion of the drawing you wish to transfer.
2) Choose the Copy option on the Edit Menu.
3) Activate the application that you wish to receive the drawing.
4) Choose the Paste option on the Edit Menu of that application.

You should be able to rescale the drawing after it is pasted into the other application.    If the 
application does not support rescaling, then you can rescale the drawing before pasting by 
opening the Windows Clipboard and changing the window size.

Notes on scaling after the transfer:
If your drawing has text objects placed inside of other objects (such as rectangles), and you 
intend to rescale the drawing after pasting it into your other application, then be aware of 
the following:    Objects such as rectangles are arbitrarily scaleable, but text objects in one of
the Raster Fonts are NOT.    After pasting into your other application, you may thus find that 
the text objects have overflowed the boundaries of the rectangles.    There are several 
solutions to this problem:

1) Use Stroke Fonts instead of Raster Fonts, since they are arbitrarily scalable.
2) Do not change the scale of the drawing.    This requires that you draw it in KwikDraw in 

the desired size.
3) Before pasting into your other application, open up the Windows Clipboard (which you 

can launch from the KwikDraw Edit Menu or from the Accessories Group in the Program 
Manager).    Scale the drawing in the Clipboard (by changing the Clipboard window size), 
until you find an acceptable fit of text to other graphics.    If you are trying to reduce the 
size of the drawing, then start your reduction by shrinking the window in the vertical 
direction first.    This should eventually cause the text object to "snap" down to the next 
available point size, which will give you a visual clue as to how far you can shrink the 
window horizontally while keeping the text objects inside their boundaries.

You can also transfer your drawing to another application as an HPGL (Hewlett 
Packard Graphics Language) file.    Several DOS and Windows based graphics compatible
word processors support this format:

1) Select the Printer Setup option from the File Menu.    This runs the Printers setup in the 
Windows Control Panel.

2) Install an HP Plotter as the default printer, printing to a file.
3) Print your drawing using the Print option on the Edit Menu.
4) Import the resulting HPGL file into your other application.



Making Objects Transparent
When one object overlaps another in your drawing, you will often want to make the top 
object transparent, so that you can see through it to the object below.    This is easy to do.    
Simply select the top object and choose the Fill option on the Pen Menu.    In the Fill Patterns 
dialog box, check the fill pattern labelled "(none)".

You should note that a transparent object can only be selected by pointing at the boundary 
of the object, whereas an object with any other fill pattern may be selected by pointing 
anywhere in its interior.



Coloring Objects
To add color to any object simply select the desired object(s) and choose either the Fill or 
Line Style Dialog Boxes, which are launched from the Pen Menu.    Use the Fill Dialog Box to 
color the internal area of closed objects, such as Rectangles, Ellipses, Closed Curves, or 
Closed Polygons.    Use the Line Style Dialog Box to color the border lines that define any 
object or to color a text object.    These dialog boxes contain three scrollbars for individually 
controlling the red, green, and blue color content.    Only solid fill patterns will use Dithered 
Colors, non-solid fill patterns and line styles will revert to the closest available Solid Color.



Modifying Objects
To make any changes to an existing object, you MUST first select it.    Once it is selected, 
perform the action listed below.

ReSizing Objects
When the object is selected, point at one of the highlighted corners with the pointer tool, 
press the mouse button (the cursor should change to an pointing hand), and drag the corner.
Release the mouse button when the desired size is obtained.    When the Constrain option on
the Layout Menu is on, the resized object will be constrained such that the aspect ratio is 
preserved.    This means that any change in object size in one dimension will be 
accompanied by a proportionally equal change in the other dimension. 

Changing Pen Width or Style
When the object is selected, choose the Line Style option on the Pen Menu.

Changing Fill Patterns
When the object is selected, choose the Fill option on the Pen Menu.

Changing Font Type, Style, or Size
When the object is selected, choose a Font Type or Style on the Font Menu, or a Font Size 
option on the Size Menu.

Flipping or Rotating Objects
When the object is selected, choose one of the Flip or Rotate options on the Arrange Menu.

Changing Polygon Vertices
To change the vertices of a Polygon, you must be in the Edit Poly mode, which can be set 
under the EditMenu.    When the polygon is selected, point at one of the highlighted vertices 
with the pointer tool, press the mouse button (the cursor should change to a pointing hand), 
drag the vertex, and release the mouse button.

Changing Extent of a Curve
To change the extent of an Arc, Pie, or Chord object, you must be in the Extend Curve mode, 
which can be set under the EditMenu.    When the object is selected, point at one of the 
curve endpoints with the pointer tool, press the mouse button (the cursor should change to 
a pointing hand), drag the endpoint, and release the mouse button.



Moving Objects
To move an object, you MUST first select it.    Once the object is selected, point at it again 
with the pointer tool, press the mouse button (the cursor should change to an open hand), 
drag the object and release the mouse button.



Editing Existing Text
You may initiate edits to an existing Text object in three ways.    Any of the methods below 
will pop-up a dialog box which will allow you to edit the text:

Using the Edit Menu:
To use this method, first select the Text object.    Then choose the Edit Text option on the Edit
Menu.

Double-Clicking:
To use this method simply double-click on the text object with the pointer tool.

Using the Right Mouse Button:
To use this method, first select the Text object.    Then press the right mouse button.



Selecting Objects
Normally, when an object is selected, the four corners of a rectangle that surrounds that 
object are highlighted.    There are a few exceptions:

- Line objects are only highlighted at the two endpoints when selected.
- When in the "Edit Poly" mode, the vertices of a Polygon object are highlighted
- When in the "Extend Curve" mode, the endpoints of an Arc, Chord, or Pie object are 
highlighted.

The Edit Poly and Extend Curve modes are discussed under Edit Menu and under Modifying 
Objects.

To Select a Single Object:
Objects are selected using the Pointer Tool.    Closed objects such as Rectangles and Ellipses 
can normally be selected by pointing the cursor anywhere inside the object and clicking the 
left mouse button.    However, if the object is using a transparent fill pattern (the default at 
startup),    then you must point near the boundary of the object to select it.    Note that a 
solid white fill pattern is not the same as a transparent fill pattern.    Lines, Arcs, and Open 
Polygons are not closed objects, so they also must be selected by pointing near the lines 
that define them.    If the object you wish to select is overlapped by another object, click on 
an exposed portion.

To Select Multiple Objects:
You can select multiple objects in one of two ways.    One method is to simply follow the 
procedure for selecting single objects, except that you hold down the Shift key when 
selecting additional objects.    To use the other method, activate the Pointer Tool, point the 
cursor outside any object, and press and hold the left mouse button.    This will initiate a 
selection box outline.    Now drag the mouse cursor, drawing an outline around all the objects
that you wish to select.    When finished, release the mouse button.    All objects falling 
completely within the selection box outline will be selected.

To Deselect Only One of Multiple Objects
If you need to deselect one object while keeping others selected, simply point at that object 
and click and release the left mouse button while holding down the Shift key.



Grouping Objects
Multiple objects may be grouped together so that they behave as a single entity with 
regards to operations such as selection, moving, scaling, flipping, rotating, alteration of fill 
patterns, line styles, or font changes.    To group several objects you must first select them.    
Then choose the Group option on the Arrange Menu.    Groups of grouped objects can be 
formed to an arbitrary number of levels.    To ungroup a group of objects, first select it and 
then choose the Ungroup option on the Arrange Menu.    Note that ungrouping a group of 
grouped objects takes you back only one level instead of all the way back to the base object 
types.



Scrolling Speed
There are three ways to use the scroll bars:

Clicking on the arrow buttons at either end of the Scroll Bar:
This method will scroll the window in incremental amounts.    It gives you a fine amount of 
control over the viewing position with visual feedback.    It is, however, the slowest scrolling 
method.

Pressing and moving the thumbscroll button in the Scroll Bar:
This method allows you to rapidly scroll to any arbitrary viewing position.    Unfortunately, 
you will not get visual feedback as you move the thumscroll because the window does not 
update until you release it.

Clicking on the region between the arrow buttons and the thumbscroll button:
This method will scroll the window in coarser increments than clicking on the arrow buttons.  
This is often the best method for panning a drawing quickly with visual feedback.


